This documentation relates to CiviCRM version 3.1. It's not maintained anymore.
Current version of documentation.

CiviCRM Documentation

Skip to end of metadata
Go to start of metadata
You are viewing an old version of this page. View the current version. Compare with Current ·  View Page History

This page refers to outdated version of CiviCRM. Check current version of documentation.


Documentation Search


CiviCRM 3.1 Documentation

Support and Participation

Developer Resources


CiviCRM book!

Make sure to check out Understanding CiviCRM as well! You can also support this project by ordering a hard copy.

CiviCRM Documentation
Support and Participation
  • How to Get Help and Help Others — CiviCRM is an Free/Open Source project. Get information on how to get help when you need it and how you can help others.
Developer Resources
  • Develop and Customize CiviCRM — We are working hard on making our software extensible and easy to customise. See information on how to create your own additions to CiviCRM.
Help to make this documentation better!

Please report any errors, omissions or suggestions to the Documentation section of our community forums

Old version!

You are viewing documentation for previous version of CiviCRM (3.1). Find current version here.

CiviCRM Primer
Get to know about it!

For more information about this version, read the release announcement.

New to CiviCRM? Read Getting Started page.

Try it!

Check out demo installation of CiviCRM 3.1 running with: Drupal.

Download!

Newest package is available on our downloads page. Be sure and download the correct version for your CMS (Drupal or Joomla), or Standalone.

Useful Shortcuts

If you are installing CiviCRM from scratch, follow below instructions:

If you are upgrading an existing site (working with a copy of the site, of course), we have provided a database upgrade script. Instructions for upgrading are here:

Technical Requirements

CiviCRM is a web-based solution that runs locally on a web server or on a virtual server provided by a hosting service. Installs on local machines should consider using the XAMPP/WAMP stacks which almost painlessly installs Apache/PHP/MySQL.

  • Apache 2.x
  • PHP 5.2.x
  • MySQL 5.x with INNODB enabled
  • Drupal 6.x
  • Joomla 1.5.x
Labels
  • None

Creative Commons License
Except where otherwise noted, content on this site is licensed under a Creative Commons Attribution-Share Alike 3.0 United States Licence.